Problem
On QAWeb Server, you receive the following issue:
This issue can have two different descriptions and root causes.
After clicking [View issue], you can see either of the following details:
Case 1:
This case is about MDRC-xxxx type displays. The detail/solution more or less already explains what is wrong. The proposed solution, however, is not entirely correct for this particular case.
Case 2:
This case is about non-Barco displays which are added to the configuration. When you attempt to calibrate these displays, this issue can happen. Read below what the root cause is and how you can solve this.
Root cause
Depending on the detailed information, this issue has two different root causes:
Case 1:
Eonis displays (MDRC-xxxx) require a USB connection between the workstation and the display in order to communicate with QAWeb Agent. Without this USB connection, the calibration cannot proceed.
Case 2:
Third-party displays which are connected to QAWeb Agent can be calibrated with QAWeb Agent and a supported external sensor. There is, however, a limitation when using Barco's MXRT display controllers. The display controller driver needs to run in 24-bit mode, whereas the default mode is 30-bit.
More technical background: When our MXRT driver is running in 30-bit, the display controller's lookup table (LUT) is locked for editing. When you calibrate a third-party display, we need to write the correction lookup table in the display controller because we cannot access the display itself. This is only possible in 24-bit mode.
Solution
Depending on the root cause, two solutions are possible:
Case 1:
Connect a USB cable between the workstation and the display and retry the action:
- Open the 'Unable to calibrate the display' issue.
- Click the [Retry or Close ...] button
- Click [Retry]
The calibration will be executed again and succeed if the USB cable is properly connected. This issue will now close automatically.
Case 2:
Change the MXRT display controller driver mode to 24 bit. The following article explains how you can do that: [KB8003]
After you have changed the driver setting to 24-bit, then retry the action. As this cannot be done remotely (you need an external sensor for calibrating a third-party display), you will need to go to the workstation and start the calibration in QAWeb Agent manually.